GET
/api/health
Gibt eine minimale JSON-Bereitschaftsnutzlast für Verfügbarkeitsprüfungen und externe Zustandsüberwachung zurück.
- Öffentlicher Endpunkt
- Gibt JSON zurück
- Keine Authentifizierung erforderlich
Diese Endpunkte können öffentlich erkannt werden und werden auf der Startseite über RFC 8288-LinkLink-Header sowie das RFC-9727-Dokument /.well-known/api-catalog .
/.well-known/api-catalog veröffentlicht einen Linkset-Katalog zur öffentlichen API-Erkennung./.well-known/agent-skills/index.json veröffentlicht einen Agent-Skills-Discovery-RFC-v0.2.0-Index für die Fähigkeiten, die diese Website kompatiblen Agenten bereitstellt./openapi.json veröffentlicht die vom API-Katalog referenzierte OpenAPI-Dienstbeschreibung./.well-known/mcp/server-card.json veröffentlicht eine MCP Server Card zur Agentenerkennung mit Peptaura-Serveridentität, unterstützter Protokollversion, Transportendpunkt und beworbenen Funktionen./.well-known/mcp-server-card stellt dieselbe MCP Server Card unter dem neueren Kompatibilitätspfad bereit, den der aktive SEP-Entwurf verwendet./mcp stellt einen öffentlichen Streamable-HTTP-MCP-Transport bereit, der derzeit Initialisierung, Ping und leere Antworten für die Tool-, Ressourcen- und Prompt-Erkennung von Agent-Clients unterstützt./.well-known/http-message-signatures-directory veröffentlicht die Web-Bot-Auth-JWKS der Website für signierte Bot- und Agentenanfragen./.well-known/openid-configuration leitet zum kanonischen Supabase-Auth-OpenID-Connect-Erkennungsdokument weiter, das für die Authentifizierung von Agenten und OAuth-Clients verwendet wird./.well-known/oauth-authorization-server leitet OAuth-orientierte Clients zu demselben aktiven Supabase-Auth-Erkennungsdokument weiter, das derzeit für OpenID Connect bereitgestellt wird./.well-known/oauth-protected-resource veröffentlicht die Metadaten der geschützten RFC-9728-Ressource mit der Ressourcenkennung dieser Website, dem Supabase-Auth-Aussteller und den unterstützten OAuth/OIDC-Bereichen, die Agenten anfordern sollten./llms.txt stellt Agenten zusätzlichen maschinenlesbaren Kontext auf Website-Ebene bereit.Accept: text/markdown an den Produktions-Hostnamen, um eine Markdown-Darstellung mit einer Content-Type: text/markdown Antwort und einem x-markdown-tokens Header, wenn Cloudflare einen bereitstellt./docs/lab-integration.md ist der Partnerleitfaden für zugelassene Prüflabore. Er dokumentiert den optionalen ausgehenden POST, den Peptaura nach Bestätigung einer Laborauszahlung an den eigenen HTTPS-Empfänger des Labors sendet, den authentifizierten /lab-Uploadablauf für Ergebnisse und die eingehende laborbezogene Partner-API: GET /api/lab/v1/orders/{clientOrderReference} für die Auftragssuche und POST /api/lab/v1/orders/{clientOrderReference}/results für die Übermittlung mehrteiliger Berichte. Die eingehenden Endpunkte erfordern eine vom Labor ausgestellte Bearer-Anmeldung und stellen nur die eigenen bezahlten Bestellungen dieses Labors bereit; sie sind Partneroberflächen, keine nicht authentifizierten öffentlichen Endpunkte wie die untenstehenden.
Eingehende Endpunkte, die jeder Client aufrufen kann. Sie unterscheiden sich von der im obigen Leitfaden beschriebenen ausgehenden Laborübermittlung.
GET
/api/healthGibt eine minimale JSON-Bereitschaftsnutzlast für Verfügbarkeitsprüfungen und externe Zustandsüberwachung zurück.
GET
/api/coasGibt das paginierte öffentliche COA-Verzeichnis mit denselben Feldern für Anbieter, Verbindung, Dosierung, Dokument-URL, Datum, Chargennummer, Reinheit, Testtyp und Herkunftsabzeichen zurück, die unter /coas angezeigt werden.
GET
/pages/product-feedGibt den öffentlichen Produktfeed zurück, der für maschinenlesbare Katalogaufnahme und -indexierung verwendet wird.