Documentación de la API pública

Estos puntos finales se pueden descubrir públicamente y se anuncian desde la página de inicio mediante encabezados RFC 8288 Linky el documento RFC 9727 /.well-known/api-catalog .

Recursos de detección

  • /.well-known/api-catalog publica un catálogo Linkset para la detección de la API pública.
  • /.well-known/agent-skills/index.json publica un índice Agent Skills Discovery RFC v0.2.0 de las habilidades que este sitio pone a disposición de agentes compatibles.
  • /openapi.json publica la descripción del servicio OpenAPI a la que hace referencia el catálogo de API.
  • /.well-known/mcp/server-card.json publica una MCP Server Card para la detección de agentes, incluida la identidad del servidor de Peptaura, la versión de protocolo compatible, el punto final de transporte y las capacidades anunciadas.
  • /.well-known/mcp-server-card sirve la misma MCP Server Card en la ruta de compatibilidad más reciente que utiliza el borrador SEP activo.
  • /mcp expone un transporte MCP HTTP Streamable público que actualmente admite inicialización, ping y respuestas vacías de detección de herramientas, recursos e indicaciones para clientes de agentes.
  • /.well-known/http-message-signatures-directory publica el JWKS de Web Bot Auth del sitio para solicitudes firmadas de bots y agentes.
  • /.well-known/openid-configuration redirige al documento canónico de detección OpenID Connect de Supabase Auth utilizado para la autenticación de agentes y clientes OAuth.
  • /.well-known/oauth-authorization-server redirige los clientes orientados a OAuth al mismo documento de detección activo de Supabase Auth que se sirve actualmente para OpenID Connect.
  • /.well-known/oauth-protected-resource publica metadatos de recursos protegidos RFC 9728 con el identificador de recurso de este sitio, el emisor de Supabase Auth y los ámbitos OAuth/OIDC compatibles que los agentes deben solicitar.
  • /llms.txt proporciona contexto adicional legible por máquina a nivel de sitio para agentes.
  • Las páginas HTML públicas también admiten Cloudflare Markdown for Agents. Envíe Accept: text/markdown al nombre de host de producción para recibir una representación Markdown con una respuesta Content-Type: text/markdown y un encabezado x-markdown-tokens cuando Cloudflare proporcione uno.

Integración de laboratorio

/docs/lab-integration.md es la guía para socios de laboratorios de pruebas aprobados. Documenta el POST saliente opcional que Peptaura envía al propio receptor HTTPS del laboratorio después de confirmar un pago de laboratorio, el flujo autenticado de carga de resultados en /lab y la API de socios entrante limitada al laboratorio: GET /api/lab/v1/orders/{clientOrderReference} para la consulta de pedidos y POST /api/lab/v1/orders/{clientOrderReference}/results para el envío de informes multipartes. Los puntos finales entrantes requieren una credencial Bearer emitida por el laboratorio y solo exponen los pedidos pagados de ese laboratorio; son superficies para socios, no puntos finales públicos sin autenticación como los siguientes.

Puntos finales públicos

Puntos finales entrantes que cualquier cliente puede llamar. Son distintos de la entrega saliente al laboratorio descrita en la guía anterior.

GET

/api/health

Devuelve una carga útil JSON mínima de disponibilidad para comprobaciones de tiempo de actividad y supervisión externa.

  • Punto final público
  • Devuelve JSON
  • No se requiere autenticación

GET

/api/coas

Devuelve el directorio público paginado de COA con los mismos campos de proveedor, compuesto, dosis, URL de documento, fecha, número de lote, pureza, tipo de prueba e insignia de procedencia que se muestran en /coas.

  • Punto final público
  • Devuelve JSON
  • No se requiere autenticación
  • Admite los filtros de /coas

GET

/pages/product-feed

Devuelve el feed público de productos utilizado para la ingesta e indexación de catálogos legibles por máquina.

  • Punto final público
  • Devuelve JSON
  • No se requiere autenticación