GET
/api/health
מחזירה מטען JSON מינימלי של מוכנות לבדיקות זמינות ולניטור תקינות חיצוני.
- נקודת קצה ציבורית
- מחזיר JSON
- לא נדרש אימות
נקודות קצה אלה בטוחות לגילוי ציבורי ומפורסמות מדף הבית דרך RFC 8288 Linkכותרות ו־RFC 9727 /.well-known/api-catalog מסמך.
/.well-known/api-catalog מפרסם קטלוג Linkset לגילוי API ציבורי./.well-known/agent-skills/index.json מפרסם אינדקס Agent Skills Discovery RFC v0.2.0 עבור המיומנויות שאתר זה מעמיד לרשות סוכנים תואמים./openapi.json מפרסם את תיאור השירות OpenAPI שאליו מפנה קטלוג ה־API./.well-known/mcp/server-card.json מפרסם כרטיס שרת MCP לגילוי סוכנים, כולל זהות שרת Peptaura, גרסת הפרוטוקול הנתמכת, נקודת קצה תעבורתית ויכולות מפורסמות./.well-known/mcp-server-card מגיש את אותו כרטיס שרת MCP בנתיב התאימות החדש יותר שבו משתמשת טיוטת SEP הפעילה./mcp חושף תעבורת MCP ציבורית מסוג Streamable HTTP התומכת כעת באתחול, ping ובתגובות גילוי ריקות של כלים, משאבים והנחיות עבור לקוחות סוכנים./.well-known/http-message-signatures-directory מפרסם את Web Bot Auth JWKS של האתר עבור בקשות בוטים וסוכנים חתומות./.well-known/openid-configuration מפנה למסמך הגילוי הקנוני של Supabase Auth OpenID Connect המשמש לאימות סוכנים ולקוחות OAuth./.well-known/oauth-authorization-server מפנה לקוחות מוכווני OAuth לאותו מסמך גילוי חי של Supabase Auth המוגש כעת עבור OpenID Connect./.well-known/oauth-protected-resource מפרסם מטא-נתונים של משאב מוגן RFC 9728 עם מזהה המשאב של אתר זה, מנפיק Supabase Auth וטווחי OAuth/OIDC הנתמכים שסוכנים צריכים לבקש./llms.txt מספק הקשר נוסף ברמת האתר, קריא למכונה, עבור סוכנים.Accept: text/markdown לשם המארח בסביבת הייצור כדי לקבל ייצוג markdown עם Content-Type: text/markdown תגובה וכותרת x-markdown-tokens כאשר Cloudflare מספקת אותה./docs/lab-integration.md הוא מדריך השותפים למעבדות בדיקה מאושרות. הוא מתעד את בקשת ה־POST היוצאת האופציונלית ש־Peptaura שולחת למקבל HTTPS של המעבדה עצמה לאחר אישור תשלום למעבדה, את תהליך העלאת התוצאות המאומת ב־/lab ואת ה־API הנכנס לשותפים בהיקף מעבדה: GET /api/lab/v1/orders/{clientOrderReference} חיפוש הזמנות ו־ POST /api/lab/v1/orders/{clientOrderReference}/results הגשת דוח multipart. נקודות הקצה הנכנסות דורשות אישור Bearer שהונפק על ידי המעבדה וחושפות רק את ההזמנות בתשלום של אותה מעבדה — אלה משטחי שותפים, לא נקודות קצה ציבוריות לא מאומתות כמו אלה שלמטה.
נקודות קצה נכנסות שכל לקוח יכול לקרוא להן. הן נבדלות מהמסירה היוצאת למעבדה המתוארת במדריך למעלה.
GET
/api/healthמחזירה מטען JSON מינימלי של מוכנות לבדיקות זמינות ולניטור תקינות חיצוני.
GET
/api/coasמחזירה את ספריית ה־COA הציבורית המחולקת לעמודים תוך שימוש באותם שדות ספק, תרכובת, מינון, URL מסמך, תאריך, מספר אצווה, טוהר, סוג בדיקה ותג מקור המוצגים ב־/coas.
GET
/pages/product-feedמחזירה את פיד המוצרים הציבורי המשמש לקליטת קטלוג ולאינדוקס קריאים למכונה.